Skip to content

Critical Advisory: Mandatory update required to address License Management Defect

What is the issue?

Matillion ETL has a critical License Management defect in Matillion ETL (v1.53.10 and above), requiring all instances to be patched or upgraded by March 31st, 2024. Failure to apply the patch or to upgrade your instances will result in the software failing to run after that date.

Step-by-step remediation instructions are available here: Remediation instructions for License Management Defect.

The new license included in the patch expires on 31st March, 2026. Additionally, the maximum number of nodes in a cluster is increased from the current 6 nodes to 9,999 nodes, which greatly increases potential throughput if needed.


What do you need to do?

For each Matillion ETL instance, the high-level steps for remediation are:

  1. Check the current Matillion ETL version.
  2. Identify whether this version is affected or not.
  3. Take a back-up, so that in the event that the patch or upgrade fails, you can fall back and restart the process.
  4. Perform the remediation, either by manually applying a patch via SSH, or via an in-client update option through the Admin menu in Matillion ETL.
  5. Perform a check to confirm the upgrade was successful.

For the detailed instructions, click here.


What if you do nothing?

All affected Matillion ETL instances will cease to function completely after March 31st, 2024. This includes all schedules and interactive usage of Matillion ETL.

After March 31st, 2024, the software will be inaccessible from the UI and the only option for fixing the problem will be installing the patch via SSH, which will require having the original SSH keys available.


Need help?

If you have any questions or if you need help with any part of the remediation instructions, contact support@matillion.com or raise a ticket at https://support.matillion.com.